
1154th Dimension User Reference

8 Quick Reports

One of the most important tasks in data management is report genera-
tion. The Quick Report editor is one of two tools used to design 
reports. You use the Quick Report editor to create ad-hoc reports in the 
User environment. The other tool is the Form editor, which you can 
use to design reports in the Design environment. You should use an 
output form to design reports that require complex designs, program-
matic processing, or graphics.

With the Quick Report editor, you can:

■ Produce lists of records

■ Create break areas

■ Compute summary calculations

■ Use fonts and styles in the report

■ Save quick report designs to disk

The Quick Report editor produces reports from the current selection of 
records. Before you print a report, set the current selection to the 
records you want to include in your report, using one of the methods 
described in Chapter 4. The following is a typical quick report. 
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Quick Report Basics
This section describes basic operations used when working with the 
Quick Report editor to design a report.

Creating a New 
Quick Report

The Quick Report editor lets you create reports in the User 
environment.

¨̈̈̈ To design a quick report:

■ Choose Quick from the Report menu.
4th Dimension displays the Quick Report editor. If an existing report 
design is displayed, choose New from the File menu to begin a new 
Quick Report design.

Loading and Saving 
a Quick Report 
Design

You can save a quick report design as a file that you can open from the 
Quick Report editor. The quick report design includes all of your speci-
fications for the report, but not the data. By saving report designs, you 
can maintain a library of quick report designs that you can use depend-
ing on your needs.

Note If you do not save your design, it is displayed the next time you open 
the Quick Report editor in that worksession only. 

¨̈̈̈ To save a quick report design:

1 Choose Save from the File menu. 
4th Dimension displays a create-file dialog box in which you can name 
the quick report design.

Note Quick report files in 4th Dimension for Windows are denoted by the file 
extension .4QR.

2 Enter a filename for the quick report and click OK. 
4th Dimension saves the report as a file that you can open with the 
Quick Report editor. You can save the file on any available hard disk.

Saving a previously saved or loaded report replaces the old report. 

Loading a Quick Report 
Design

When the Quick Report editor is open, you can load a saved design 
and use it to print a new report. You can use the same quick report 
design repeatedly to print different selections of records.
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¨̈̈̈ To load a report design:

1 Choose Open from the File menu. 
4th Dimension displays an open-file dialog box displaying a list of 
available quick report designs. 

2 Double-click a filename or select a filename from the list and click OK.
4th Dimension replaces the current report design with the design you 
opened. 

The Quick Report Editor
When you create a quick report, you can specify the following:

■ Columns that display fields or formulas, either from the current table 
or from related tables

■ Sort levels and order

■ Break levels

■ Summary calculations

■ Text for labels

■ Formats for numeric and Boolean data

■ Font, font size, style, and justification for labels, summary calculations, 
and data

■ Page headers and footers

The following illustration shows the major elements of the Quick 
Report editor.
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The Quick Report editor contains the following elements: 

■ Fields list  This list displays fields in the current table. You can view the 
names of fields in related tables by expanding the foreign key fields. A 
foreign key field has a plus sign (on Windows) or an arrow (on 
Macintosh) to its left.

Note Only tables and fields which are visible appear in the Quick Report 
editor. For information about making tables and fields invisible, refer 
to the 4th Dimension Design Reference.

■ Sort list  This list displays the sort order assigned to the report and 
indicates whether each sort level is ascending or descending. If your 
report will contain summary calculations from groups of records, you 
must sort the current selection on one or more fields. 

Note You can change the order of fields in the Sort list by dragging the field 
name vertically to the desired position in the list.

■ Quick Report area  You use this area to design the report by dragging 
fields, adding formulas, adjusting column widths, and adding or 
deleting breaks.

■ Summary calculation buttons  You use these buttons to place summary 
calculations in the Break and Total areas of the report.
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■ Column properties  You use these check boxes to set the following 
characteristics for each column in the report: 

■ Sorted  Click this check box if you want the records to be sorted on 
the selected column. 

■ Repeated Values  You use this check box to tell the Quick Report 
editor to repeat the values in a Break column. If you do not select the 
Repeated Values check box, each Break value is displayed only once.

■ Automatic Width  Click this check box to request that the Quick 
Report editor compute the width of the selected column based on 
the maximum length of the contents of the column. The sizing is 
done only at the time the report is printed. You can check this 
option for each column individually. The check box does not refer 
to the entire report. If the Automatic Width check box is not 
checked for a column, you can modify that column’s width by drag-
ging column dividers.

■ Column dividers  These lines indicate the boundaries between columns 
of the report.

■ Right margin marker  This marker indicates the right margin of the 
report. The right margin marker is meaningful only when no columns 
have the Automatic Width check box selected. You may have to scroll 
horizontally to view the right margin marker.

■ Column header  The column header displays the names of fields or 
formulas added to the report. 

■ Row label bar  This bar shows the different areas of the report: the 
Header, Detail, Break, and Total rows. 

■ Header row  This row contains information that appears in the printed 
report above the records. The Quick Report editor automatically places 
field names in the Header row, but you can modify its contents. 

■ Detail row  This row prints information from individual records and 
will be repeated in the printed report for each break. 

■ Break and Totals rows  These rows display summary calculations and 
any associated labeling. The Break row displays summary calculations 
for each subgroup in the report and the Totals row displays summary 
calculations obtained from all records in the current selection.

■ Cells  A cell is the intersection of a row and a column.
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■ Scroll bars  You use the scroll bars to view parts of the quick report 
design that extend beyond the area of the quick report form. 

The following figure shows a completed quick report design and the 
relationship between the specifications in the design and the printed 
output.

Resizing Areas in the 
Editor

You can resize the various list and display areas in the Quick Report 
editor. Areas that can be resized are bordered by a raised line.

¨̈̈̈ To resize an area in the editor:

1 Move the pointer over the area border to change the pointer into a 
resizing pointer  or . 

2 Drag the border up or down, or left or right to resize the area. 

The Quick Report Pop-up Menus
The Quick Report editor has “hidden” pop-up menus that make it easy 
to access certain row, column, and cell operations. Instead of making 
menu selections or working with the Cell or Column properties areas, 
you can perform certain operations by displaying a Quick Report pop-
up menu.

There are separate pop-up menus for row, column, and cell operations.
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¨̈̈̈ To use a pop-up menu:

1 Position the pointer in a cell, a row label, or a column heading and 
hold down the mouse button.
A pop-up menu appears. The commands in the pop-up menu depend 
on where your pointer is (i.e., a row label, column heading, or cell). 
Also, menu commands that are inappropriate for the particular row, 
column, or cell are disabled.

The following illustration shows the three Quick Report pop-up 
menus.

2 Choose the desired menu command.
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Working with the Quick Report Editor
This section describes the basic operations that you can perform in the 
Quick Report editor.

Selecting Rows, 
Columns, and Cells

When designing a quick report, you need to select rows, columns, and 
cells in the quick report form. A cell is the intersection of a row and a 
column.

¨̈̈̈ To select a row:

■ Click on the Header, Detail, Break, or Total markers on the row label 
bar to the left of the Quick Report form.
OR
Click in a row to the right of all columns in the Quick Report form. 

¨̈̈̈ To select a column:

■ Click above the Header row of a column. 

¨̈̈̈ To select a cell:

■ Click the cell.

Adding and 
Modifying Text

You can add or modify text in the quick report form to label parts of the 
report. For example, if you requested summary calculations, you can 
label them by adding text to other cells in the Break and Total rows.

You can add and modify text as follows:

■ Edit the text that 4th Dimension automatically adds to the Header row 
of the report

■ Insert text in empty cells of the Break and Totals rows

■ Insert the value of a Break field in the Break rows

■ Specify the font, font size, justification, and style for any text that 
appears in the report

Adding Text To add text in a report cell:

1 Click twice on an empty cell in the quick report form.
A text insertion point appears in the cell.

If you are entering a label for a summary calculation, select a cell in the 
same row as the cell containing the calculation icons. You cannot enter 
text into the same cell that contains summary calculations.
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2 Type the text in the cell. 

Modifying Text To modify text in a cell:

1 Double-click in a cell to get an insertion point and drag across the text 
in the cell you want to modify.
4th Dimension highlights the selected text.

2 Type the new text in the cell.

Specifying Font 
Attributes

While designing your quick report, you can specify different fonts, 
font sizes, justification, and styles. You can then apply these specifica-
tions to text, data, and summary calculations within rows, columns, or 
cells in the quick report.

If you assign specifications to the Detail row of the report, you will not 
see the results until you preview or print the report.

You can specify font attributes using either the Quick Report menu 
commands or the Quick Report pop-up menu.

¨̈̈̈ To specify font attributes using the Quick Report menus:

1 Select the column, row, or cell where you want to apply the font.

2 Choose a font from the Font menu or choose a font size, style, or 
justification from the Style menu.
4th Dimension applies the font to any text, data, or summary 
calculations that appear in the selected area.

¨̈̈̈ To specify font attributes using the Quick Report pop-up menu:

1 Hold down the mouse button on the row label, column header, or cell 
to which you want to apply the font attributes.
A pop-up menu appears.
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2 Use the Font, Size, Style, or Alignment hierarchical menus to change 
the font attributes as desired.

Adding Columns to 
the Report

You create columns by dragging field names from the Fields list in the 
to the quick report area. If you want to add a field from a related table, 
expand the foreign key field in the hierarchical list of fields to display 
the fields in the related table. You can add fields from related tables, 
provided that the relationship is automatic.

¨̈̈̈ To add a field:

■ Drag the name of a field to the right of existing columns in the Quick 
Report area and release the mouse button.
4th Dimension creates a column for the field and places the field name 
in both the column header and the cell in the Header row. 

The following figure shows the Last Name field being added as a 
column to the Quick Report area.
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By default, 4th Dimension prints the field names as column heads at 
the top of each page in the quick report.

Note If you use a subfield in a quick report design, the report will list all 
values of the subfield for each parent record. You cannot sort on a 
subfield.

Inserting Columns You can insert an empty column in a quick report. After you insert the 
column you can assign a field or a formula to the column.

¨̈̈̈ To insert a column:

1 Select a column.

2 Choose Insert Column from the Edit menu.
OR
Hold down the mouse button to display the Quick Report pop-up 
menu and choose Insert Column.
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4th Dimension inserts a blank column to the left of the column you 
selected. To assign a field to the empty column, drag a field name to it. 
To assign a formula to the column, see the section “Adding Formulas 
to a Quick Report” on page 128.

Deleting Columns As you specify fields for your quick report, you may want to remove 
some columns to place them elsewhere. Or, you might want to delete 
the column from the report.

¨̈̈̈ To delete a column using the Quick Report menu bar:

1 Select the column you want to delete. 

2 Choose Delete Column from the Edit menu. 
4th Dimension removes the selected column from the quick report 
form. 

¨̈̈̈ To delete a column using the Quick Report pop-up menu:

1 Hold down the mouse button on the column header.
The Quick Report pop-up menu appears.

2 Choose Delete Column from the pop-up menu.
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Replacing Columns You can replace a column in the quick report by dragging another field 
over it. You can also replace a field with a formula.

¨̈̈̈ To replace a column:

1 Drag a field from the Fields list to the column you want to replace.
OR
Select the column you want to replace and choose Edit Column from 
the Edit menu. 
OR
Hold down the mouse button on the column header to display the 
Quick Report pop-up menu and choose Edit Column.
The Formula editor appears.

2 If you displayed the Formula editor, enter a formula for the column.
If you want to assign a field to the column, you can simply use the 
field name as the formula.

When you print the quick report, 4th Dimension prints the results of 
the formula for each record that appears in the Detail row. 

See the section “Adding Formulas to a Quick Report” on page 128 for 
information about adding a formula to a quick report.

Sizing Columns By default, the Quick Report editor sizes columns automatically (as 
reflected in the Automatic Width check box). It sizes each column 
based on the maximum length of data displayed in the column and 
any labels typed into the column. The Quick Report editor sizes 
columns at the time the report is printed. 

To view the widths of each column, preview the report to the screen. 
See “Printing a Quick Report” on page 142 for more information about 
previewing the report. 

Because selecting the Automatic Width check box changes the width of 
a column based on the maximum width of data in the records being 
printed, selecting different records can change the size of the columns. 

You can resize a column manually after deselecting the Automatic 
Width check box. When a column is set manually, text in the column 
wraps within the specified area.

¨̈̈̈ To manually resize a column:

1 Select the column you want to resize.
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2 Deselect Automatic Width1. 

1. You can deselect Automatic Width using either the check box in the Col-
umn Properties area or the Quick Report pop-up menu for that column.

3 Move the pointer over the column divider in the quick report to 
change the pointer into a column width cursor . 

4 Drag the column divider to the left or right to resize the column. 

Adding Formulas to 
a Quick Report

You can add a formula to a column in a quick report. For example, you 
can add a formula that computes employees’ monthly salaries from an 
Annual Salary field.

¨̈̈̈ To add a formula:

1 Insert an empty column or click an existing column and choose 
Edit Column from the Edit menu.
OR
Double-click an existing column. 
OR
Hold down the mouse button on an existing column header to display 
the Quick Report pop-up menu and choose Edit Column.
4th Dimension displays the Formula editor, in which you can build a 
formula. If you selected an existing column, the formula you create 
will replace the previous contents of the column.

Note Make sure that the formula you create does not change the current 
selection. Changing the current selection will cause problems when 
you print the quick report since the report is based on the current 
selection. For information about commands and functions that change 
the current selection, refer to the 4th Dimension Language Reference.

2 Build the formula. 
OR
Click the Load button to retrieve an existing formula from disk.

For information about using the Formula editor, refer to “The Formula 
Editor” on page 93.

To save the formula as a file that you can retrieve and use in another 
column or in another report, click the Save button and enter a 
filename in the dialog box.

If you click the Load button, 4th Dimension displays an open-file 
dialog box and asks you to select a file. When you load a file, it replaces 
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any formula that currently appears in the Formula editor. After you 
load a formula, you can modify it in the editing area.

3 Click OK to assign the formula to the column.
4th Dimension adds a new label to the column that identifies it as a 
formula. You can relabel the column by typing a label into the header 
cell for that column. 

Formulas are labeled C1 through Cn. The labels are the names of 
variables that contain the column’s value. You can use these variables 
in other formulas.

Click the Cancel button to close the editor and return to the Quick 
Report editor without adding the formula.

Sorting Records and Creating Breaks
An important feature of the Quick Report editor is the ability to sort 
the records in your report. You sort records for two reasons:

■ To view records in a particular order,

■ To create groups of records and Break areas in the report for the 
purpose of reporting summary calculations for groups. 

See the section “Setting Break Levels” on page 131 for information 
about summary calculations.

Specifying a Sort 
Order

You can specify a sort order at any time. For example, if you wanted to 
sort the records of salespeople by the Sales Region field, you would 
select the Sales Region column, and then set the Sorted property.

You can also sort on a formula by selecting the column that contains 
the formula and then clicking the Sorted check box or choosing 
Sorted from the Quick Report pop-up menu for that column. See the 
section “Adding Formulas to a Quick Report” on page 128 for more 
information about adding formulas to quick reports.

¨̈̈̈ To specify the sort order using the Sorted check box:

1 Select the column that contains the field or formula you want to 
specify as the first sort level.

2 Click the Sorted check box.
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¨̈̈̈ To specify the sort order by dragging:

■ Drag a field from the Fields list to the Sort order list.
If the field is not already in the quick report design, 4th Dimension 
adds it as the last field in the design.

¨̈̈̈ To specify a sort order using the Quick Report pop-up menu:

1 Hold down the mouse button on the column header belonging to the 
column you want to sort.
The Quick Report pop-up menu appears.

2 Choose Sorted from the pop-up menu.
4th Dimension displays the name of the field in the Sort list. To the 
right of the name is an arrow, indicating an ascending sort order. By 
default, all sorts are performed in ascending sort order. 

3 If necessary, click the sort direction arrow  to sort the column in 
descending order.

4 If desired, select additional fields or formula columns and add the 
Sorted property using either the Sorted check box or pop-up menu 
command.
You can specify ascending or descending sort order for any additional 
fields or formulas you specify.

When you specify multiple sort levels, 4th Dimension sorts the records 
on the first field in the Sort field list, then on other fields in the order 

Sort direction arrow

Sorted check box
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that they appear in the list. For example, if you specify the Department 
Name field as the first sort level and Last Name as the second sort level, 
your design might look like the quick report design shown in step 3.

¨̈̈̈ To change the level of a Sort field:

■ Drag the name of a field or formula up or down within the Sort list to 
the desired sort level.

Deleting a Field or 
Formula from the 
Sort List

You can delete the any field or formula from the Sort list.

¨̈̈̈ To delete a field or formula from the sort order:

■ Select the column and deselect the Sorted check box.
OR
Hold down the mouse button on the column header to display the 
Quick Report pop-up menu and deselect the Sorted menu command.
4th Dimension removes the field or formula in the Sort field list. It does 
not delete the column itself from the report. When you print the 
report, 4th Dimension will no longer use that field or formula to sort 
the records. 

Setting Break Levels In a quick report, you set break levels to separate or “break” records 
into groups according to values in one or more sort fields. A Break area 
is printed at each break level. You can print summary calculations in 
the Break area. The summary calculations — sum, average, minimum, 
maximum, and count — are calculated for each group of records. 

Break levels are determined by the sort levels and Break rows. For 
example, if you sort records by Sales Region and create a Break row, 
4th Dimension inserts a break between each group of records that have 
the same sales region. 

After you add a Break row to the quick report, you can request sum-
mary calculations on each break. For example, you can insert a sum-
mary calculation in a Break row to display subtotals for sales from each 
state in a marketing region. Refer to the section “Adding Summary Cal-
culations” on page 133 for more information about adding summary 
calculations to Break and Total rows.
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¨̈̈̈ To insert a Break row:

1 Choose Add Break from the Edit menu.
OR
Hold down the mouse button on the Total row label in the Row label 
bar and choose the Duplicate Break menu command.
4th Dimension adds a Break row. The figure shows a Break row in a 
quick report design.

2 If desired, add additional Break rows by repeating step 11. 
There should be at least as many sort levels as break levels.

4th Dimension adds a sequential number to each new break label in 
the row label bar, for example, Break1, Break2, Break3, and so forth.

1. After you have created a Break row, you can also display the Quick Report 
pop-up menu by holding down the mouse button on the new Break row label.

Using the Values of 
Break Fields in 
Labels

You can improve the appearance and comprehensibility of your 
reports by labeling each Break row using the value of the Break field.

To request that the value of a Break field be printed in a label placed in 
the Break area, use the number sign (#) in the label. For example, the 
text “Total salaries for department #” will insert the department name 
(in this case, the value of the Department field) in place of the number 
sign when the report is printed.

The number sign does not need to be placed in the same column as the 
Break field. It will display the value of the Break field in any cell in the 
Break row.

The following figure illustrates the use of the number sign in a label in 
the Break row.

Break row
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Adding Summary Calculations
You can add summary calculations on the contents of fields and 
formulas to each Break row and to the Totals row.

The check boxes in the Cell area of the Quick Report editor identify the 
summary calculation options available for quick reports. The following 
summary calculations are available.

■ Sum  totals the values in the report or break.

■ Minimum  displays the lowest value in the report or break.

■ Maximum  displays the highest value in the report or break.

■ Average  calculates the average of the values in the report or break.

■ Count  calculates the number of records in the report or break.

These options also appear in the Quick Report pop-up menu for cells in 
the Break and Total rows.

When you place a summary calculation in the Totals row, the 
calculation is done for all records in the report. If you place the 
summary calculation in a Break row, separate calculations are done for 
the records in each break. 

Number sign 
used in label
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¨̈̈̈ To add a summary calculation:

1 Select a cell in a Break row or in the Totals row where you want to 
insert the summary calculation.
The Sum, Minimum, Maximum, and Average calculations work only 
on a numeric field or formula. 

2 Click as many summary calculation check boxes as you like. 
Or
Hold down the mouse button and choose the desired summary 
calculations from the Quick Report pop-up menu for cells.
4th Dimension displays a calculation icon in the selected cell for each 
type of summary calculation you request. The following figure shows 
calculation icons in the Break and Total rows.

If you add more than one summary calculation to a cell, 
4th Dimension stacks the calculation icons on top of each other, as 
shown above.

Displaying Repeated 
Values for Break 
Columns

In a report with breaks, the columns which are used to group records 
so that summary calculations can be done are called Break columns. In 
the report shown above, the Department field is a Break column since 
the records in the report are grouped by department.

When a report like this is printed, the values for the Break column are 
printed only once per break. In other words, a department name is 

Calculation icons in 
Break and Totals 
rows
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printed only for the first record in the group and is not repeated until 
the department changes.

In some cases, you may want to repeat the values for the Break col-
umns so that they appear for every record in the Break area. You do so 
by selecting the Repeated Values column property. You can do so 
either by clicking the Repeated Values check box in the Column Prop-
erties area or by choosing the Repeated Values menu command in the 
Quick Reports pop-up menu for that column.

¨̈̈̈ To display repeated values for fields in Break columns:

1 Select the Break column by clicking above the Header row for that 
column and click the Repeated Values check box.
OR
Hold down the mouse button on the Header row of the Break column 
and choose Repeated Values from the Quick Reports pop-up menu.

The following figure shows the report at the top of this page after the 
Repeated Values check box has been checked for the Department 
Name column.

Nonrepeating 
break values
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Setting Display Formats
You can specify display formats for columns that contain numeric or 
alphanumeric (Alpha) data. For example, if you are displaying salaries 
in a column, you can add a numeric format to the Detail cell for the 
Salary field. If your report includes Alpha fields such as a telephone 
number or Social Security number, you can use an Alpha format.

Numeric Formats The following format places a dollar sign to the left of the number and 
allows up to 6 digits:

$###,###

This format can display dollar amounts up to $999,999. 

You can also create custom display formats in the Database Properties 
dialog box and use them in Quick Report designs. For more informa-
tion about creating custom formats, refer to the 4th Dimension Design 
Reference.

Alpha Formats You can use an Alpha format for fields that contain string information. 
For example, Social Security number or telephone number fields can be 
formatted with an Alpha format. 

For example, the following format would be used to format Social 
Security numbers:

###-##-####

Numeric 
format
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Entering the Display 
Format for a Field

You enter a display format or custom format by choosing it from the 
Quick Report pop-up menu for the cell or by typing it into a cell.

¨̈̈̈ To enter a display format for a numeric or Alpha field:

1 Click twice in the Detail cell for a numeric or Alpha column.

2 Type a display format or the name of a style that you want to use as 
the display format.
The names of styles are preceded by a vertical bar (|).

¨̈̈̈ To choose a display format from the Quick Report pop-up menu:

1 Position the pointer over the Detail cell for a column and hold down 
the mouse button and choose a display format from the hierarchical 
menu.

The hierarchical menu will show display formats that are appropriate 
for the data type of the column. For example, if the field was a numeric 
format, the menu command would be “Numeric” instead of “Alpha” 
and the submenu would list only numeric formats.

After you make your selection, you can edit the format normally.

If you have also requested summary calculations for that column, the 
format specified in the Detail cell will automatically be applied to the 
summary calculations. Regardless of the display format, the count is 

Display formats for 
Alpha fields

Menu command 
indicates field type
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always displayed as an integer without formatting symbols such as the 
dollar sign.

Different formats can be applied to different columns in the report. 

Hiding and Showing Rows and Columns
4th Dimension lets you hide rows or columns when printing a quick 
report. If desired, you can show a hidden column or row.

Hiding rows is useful when you want the report to include only sum-
mary calculations. For example, hide the Detail row if you want to dis-
play only the summary calculations that appear in the Totals and Break 
rows. You can also use this feature to hide a Break row or the Totals row.

You can hide a column if you need to use the column as a sort column, 
but do not want the report to display the column. 

You can hide a row using either a Quick Report menu command or the 
Quick Reports pop-up menu.

¨̈̈̈ To hide a row using the menu command:

1 Select the row you want to hide.

2 Choose Hide from the Edit menu. 

¨̈̈̈ To hide a row using the pop-up menu:

1 Hold down the mouse button over the row label in the Row label bar.
The Quick Reports pop-up menu appears.
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2 Choose Hide from the pop-up menu.
4th Dimension displays the column in gray to remind you that the row 
will not appear when you print or preview the quick report.

You can also use a menu command or the Quick Reports pop-up menu 
to hide a column.

¨̈̈̈ To hide a column using the menu command:

1 Select the column you want to hide.

2 Choose Hide from the Edit menu.

¨̈̈̈ To hide a column using the Quick Reports pop-up menu:

1 Hold down the mouse button over the column header.
The Quick Reports pop-up menu appears.

2 Choose Hide from the pop-up menu.
4th Dimension displays the column in gray to remind you that it will 
not appear in the printed report. 

Hidden row
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Showing a Hidden 
Row or Column

When a row or column is hidden, the Hide menu command in the Edit 
menu and Quick Report pop-up menu becomes Show. You can display 
a hidden row or column choosing Show from either the Edit or pop-up 
menu. When you do so, the row or column is displayed normally in 
the Quick Report area.

Adding Page Headers and Footers
Before printing a quick report, you can add page headers and footers. 
You specify page headers and footers in the Headers and Footers dialog 
box. Use this dialog box to do the following:

■ Add page header and footer text,

■ Specify the size of the page header and footer areas,

■ Specify fonts, font sizes, and font styles for page header and footer text,

■ Insert codes that add page numbers and the date and time to your 
reports.

You can only specify page headers when printing to a printer. See the 
section “Printing a Quick Report” on page 142 for more information 
about alternate output devices.

¨̈̈̈ To add page headers and footers:

1 Choose Headers and Footers from the File menu.
The Headers and Footers dialog box appears.

Hidden column
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The Header and Footers dialog box lets you specify both headers and 
footers from the same screen. You use the Edit drop-down list to 
specify either the header or footer.

2 Choose Header or Footer from the Edit menu.

3 Enter the header or footer height in the Height area. 
When you first enter the dialog box, the header and footer heights are 
set to 25 points each. You can change values for the height and can 
change measurement scale to enter values in inches or centimeters.

As you enter the header and footer height, the dotted lines on the page 
preview area change to indicate the size of the header and footer as 
they will appear on the printed report.

4 Select an entry area and type the header or footer text.
To the right of each entry area is a pop-up menu that lets you insert 
variables into the entry area. 

You can insert the current page number, time of printing, or date of 
printing.

Page preview 
area

Height

Measurement scale 
drop-down list

Edit drop-down list
Header and Footer 
entry areas

Header and footer 
variables
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To insert a variable, choose it from the pop-up menu. 4th Dimension 
inserts the variable in the entry area at the insertion point. You can 
combine variables with text.

Specifying Font, 
Attributes

You can specify different fonts, font sizes, justification, and styles for 
page headers and footers. 

¨̈̈̈ To specify font attributes:

■ Choose a font and font size from the drop-down lists and click one or 
more Style check boxes.
Your specifications are applied to all three entry areas. You cannot 
apply different font attributes to different areas of the header or footer.

Some Style combinations are not valid. For example, you can choose 
Bold and Italic, but you cannot choose both Plain and Bold.

Printing a Quick Report
After you have completed your report design, you can print the quick 
report. You can print a quick report to a variety of output devices:

■ On the standard printer selected in the Print Manager (the Chooser on 
Macintosh)

■ To disk

■ To a graph

¨̈̈̈ To select an output device:

■ Choose Print Destination from the File menu. 

The Print Destination hierarchical menu contains three items.

Printer This option uses the printer you have chosen in the Print Manager 
(Chooser on Macintosh). You can print to a printer without using the 
Print Destination item by choosing Print from the File menu. If you are 
printing to a printer, you can preview the report before printing it. 



Printing a Quick Report

1434th Dimension User Reference

¨̈̈̈ To print to a printer:

1 Choose Print from the File menu. 

2 Click the OK button and follow the standard 4th Dimension procedure 
for previewing and printing your report. 
For more information about printing, see the section “Printing 
Standard Reports” on page 110.

3 Choose the settings that are appropriate for your report and click the 
OK button.

Disk File This option sends your quick report to a disk file that you can open 
and modify with other applications, including text editors and spread-
sheets. This option exports the records in the quick report to a text file.

When you use this option, 4th Dimension automatically uses the 
column headings as the first “record” that is exported.

¨̈̈̈ To print to a disk file:

1 Choose Disk File from the Print Destination hierarchical menu.

1 Choose Print from the File menu. 
4th Dimension displays a standard create-file dialog box and asks you 
to enter a filename. 

2 Enter a filename and click the OK button.
4th Dimension displays a dialog box that keeps you informed of the 
progress of the operation. Click the Stop Printing button to cancel the 
operation.

After the report is printed to a file, 4th Dimension returns you to the 
Quick Report editor. Remember to change the output device if you 
want to resume sending a quick report to a standard printer.

Print to Graph This option directs the report to 4D Chart, 4th Dimension’s plug-in for 
plotting data. When you choose the Graph item in the Print 
Destination hierarchical menu, your report is presented as a graph 
rather than in tabular form. 4D Chart uses only the summary 
calculations and labels in the Break row. It uses the leftmost non-
numeric column for the Values axis (the horizontal axis).

To use the Graph feature, your report should:

■ Include from one to five numeric fields or formulas. These columns 
will be assigned to the values axis in the graph.
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■ Use one type of summary calculation per numeric field.

For example, if you want to graph average salary by department, you 
should create a quick report with two columns, Department Name and 
Salary. Use the Average summary calculation for Salary.

¨̈̈̈ To print to a graph:

1 Choose Graph from the Print Destination hierarchical menu.

2 Choose Print from the File menu. 
4th Dimension graphs your data as a column graph. 

The following figure shows the graph produced from the quick report 
design shown above.

Value to be 
graphed
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You can use 4D Chart to select another graph type or print the graph. 
For more information about the options available in 4D Chart, see the 
section “Creating a Graph” on page 172.


